サンプルの活用

概要

テクスチャの適用では、建物モデルについては、テクスチャを貼り付けてより見栄えの良いものにしましたが、道路についても、Esri が提供するサンプル データを活用すれば簡単にリアリティを増すことができますので、その方法を紹介します。

演習
サンプル データの入手
サンプル データの利用
編集したサンプル データの利用
ルールの属性を変更
その他のサンプル

サンプル データの入手

CityEngine のサンプル データは、現在使用している「Esri.lib」や「City Wizard」に含まれるもの以外にも、Help メニュー [Download Tutorials and Examples] から取得できる Tutorials や Examples、さらには Esri のオンライン サービスである「ArcGIS Online」から入手できるものがあります。
どちらも無償ですのでこれを活用しない手はありません。ここでは Download Tutorials and Examples から取得する方法をご紹介します。

CityEngine アプリケーションからダウンロードする

  1. Help メニュー [Download Tutorials and Examples] を選択します。

  2. 表示されたダイアログから、[Example Complete Streets 2019.1] チェックボックスをオンにし、[Finish] をクリックします。

  3. しばらくすると Navigator ウィンドウにダウンロードした [Example_Complete_Streets__2019_1] が表示されます。 Example Complete Streets には高度な道路用 CGA ルール ファイルが格納されています。
    Navigator ウィンドウ上にあるプロジェクトのルール ファイルは、そのまま他のプロジェクトにも適用できます。

サンプル データの利用

  1. Scene ウィンドウの Streetnetwork レイヤーを展開し、Blocks レイヤーの表示チェックボックスをオフにして非表示にします。

  2. Network レイヤーを選択 [Select] メニュー [Select Objects in Same Layer] を選択するか、または 3D View ウィンドウで [Selection] ツールを使い、道路ネットワークをすべて選択します。
    ここで、Inspector ウィンドウを開き、パラメーターを確認します。
    現在適用されているルール ファイル (Street_Modern_Standard.cga) は Esri.lib に格納されている簡単な道路のルール ファイルですので、パラメーターも多くありません。 では次に Example Complete Streets の道路ルール ファイルを適用してみましょう。

  3. Navigator ウィンドウ [Example_Complete_Streets__2019_1] → [rules] → [Streets_Complete] → [complete_street.cga] ルール ファイルを、選択した道路ネットワークにドラッグ & ドロップします。

自身のプロジェクトにExample Complete Streets プロジェクトの道路ルールが適用されました。
Inspector ウィンドウを開き、パラメーターを確認してみましょう。

先ほどの Street_Modern_Standard.cga のルール ファイルと違い、パラメーター数がかなり多いのが分かります。
つまり、道路に関する詳細な設定が行えるということです。見た目では違いが分かりにくいので、道路幅を広げます。

  1. 道路を選択した状態で Inspector ウィンドウの [Segments] タブ [streetWidth] で値を 12 に変更します。または、ツールバー上の Edit Streets/Curves ツールで対話的に変更しても構いません。

  2. 日本にはあまり 環状交差点 はないので、普通の道路形状に変更します。
    Inspector ウィンドウの [Node] タブ [type] で [Crossing] に設定します。

  3. Inspector ウィンドウの [Shape] タブで、用意されているさまざまなパラメーターを任意に変更してみましょう。
    例えば、 [ROAD LAYOUT] → [Basic Components] → [Centerline_Color] を [White] に変更すると、中心線の色が変わります。

このように Esri が提供している Example Complete Streets サンプルなどを使用すれば、高度なルールファイルを自身のシェープに適用して、簡単にモデルを作成することができます。

しかし、Example の素材は西洋的なものが多いので、日本のデータに適用するとしっくりこない場合があります。そんな時は、ルール ファイルを少し編集して、日本風にすることができます。
今回は、 Example Complete Streets のルール ファイルとアセットを少し編集して道路標示を日本語にしたものや、電線などを生成するルールを追加したサンプルをご用意しましたので、それを利用してみましょう。

編集したサンプル データの利用

これから行う作業は Example Complete Street の一部を変更します。変更後、オリジナル のルールも引き続き利用できますが、完全に戻した いという場合は、再度 Help メニューよりダウンロードしてください。

  1. ArcGIS Online のページから日本語用サンプル データを任意の場所にダウンロードします。

  2. ダウンロードした Zip ファイルを展開し、中に格納されている assets フォルダーと rules フォルダーをワークスペース内の Example_Complete_Streets__2019_1 フォルダーにコピー & ペーストし、上書き保存します。

  3. CityEngine を再起動し、Scene ウィンドウの Network レイヤーを選択し、右クリック [Select Objects] を選択するか、または 3D View ウィンドウで [Selection] ツールを使い、道路ネットワークをすべて選択します。

  4. Navigator ウィンドウ → [Example_Complete_Streets__2019_1] → [rules] [Streets_Complete] → [Complete_Street_jp.cga] を選択した道路に適用します。
    下図のように左側通行になったり、英語だった道路表記が日本語になったり、元のルール ファイルにルールを追記することで電柱・電線を生成したりすることができます。
    このようにルール ファイルやアセットを少し変更するだけで、一から作成しなくても、自分の目的に合わせてモデルを生成することができます。

ルールの属性を変更

道路ネットワークに適用した Complete_Street_jp.cga には、様々なパラメーター (属性) が用意されており、Inspector で直接入力やスライダーバー、プルダウン メニュー等で値を変更することができます。

  1. 道路が選択されていない場合は、再度 Scene ウィンドウで Streetnetwork / Network を右クリックし、[Select] → [Select Objects] を選択してすべての道路ポリゴンを選択します。

  2. Inspector で属性を変更します。属性には例えば次のような項目があります。

中央分離帯を作成

① Complete_Street_jp / CENTER SECTION LAYOUT / Basic Attribute / Center_Type を [Barrier] に変更します。

街路樹の表示

② Complete_Street_jp / CENTER SECTION LAYOUT / Basic Attribute / Center_Type を [Median] に変更し、 Center_Width を [2] に設定します。中央分離帯に、自動的に街路樹が生成されます。
③ Complete_Street_jp / CENTER SECTION LAYOUT / Basic Attribute / Median Plantings / Median_Tree_Spacing を [5] に変更します。
また、Median_Tree_1_Type で任意の樹木タイプに変更します。

自動車や方向者の表示

④ Complete_Street_jp / POPULATION / Vehicles_per_km (車線上 1 km 区間あたりの車の台数) を [20]、People Percentage (歩道上の単位エリアでの人の存在確率) を [3] にします。数値を大きくすると表示モデルが増えて パフォーマンスが遅くなりますので注意してください。

電柱・電線の表示

⑤ Complete_Street_jp / Power Lines Construction / Show_Power_Lines を [Enabled] にします。電柱と電線が表示されます。
⑥ Complete_Street_jp / PowerLines / poleDiam で電柱の太さを設定できます。
⑦ Complete_Street_jp / PowerLines / poleDist で電柱の間隔を設定できます。
⑧ Complete_Street_jp / PowerLines / powerlineLineHeight で電線の高さを設定できます。

ガードレールの表示

⑨ Complete_Street_jp / GuardRailsImport / guard_rails を [Enabled] にします。ガードレールが表示されます。

他にも様々な項目がありますので、設定を変更してみてください。 道路の設定が終了したら、Scene ウィンドウの Streetnetwork レイヤーを展開し、Blocks レイヤーのチェックボックスをオンにし、区画を表示させます。

その他のサンプル

ArcGIS Online には他にも砂漠の都市 (Example Desert City) やヴェニス (Example Venice)、ポンペイ (Example Pompeii)、未来のニューヨーク (Example NY2259)、中世の都市 (Example Medieval City)、破壊された街 (Example Downtown Damage) などのサンプルがありますので、これらに含まれるルールを適用してみると面白いと思います。
ちなみに、先ほど使用した Complete_Street_jp の中の電柱と電線も、Example Desert City のルールをほとんどそのまま移植したものです。
このようなルールを自分で 0 から書くのは大変ですが、どのサンプルにどういうルール (モデル) があったか頭の片隅にでも入れておけば、それを利用して楽をすることができます。