プロジェクトの作成

概要

プロジェクトを新規作成してデータを作成するまでを学びます。

CityEngine では、プロジェクト単位でデータを管理します。新規プロジェクトを作成すると、[Navigator] ウィンドウにプロジェクト フォルダーが表示されます。 そしてプロジェクト フォルダー下には assets、data、images、maps、models、rules、scenes、scripts の 8 つのフォルダーが自動的に作成されます。 この各フォルダー内にプロジェクトで必要なデータや画像、ルールやテクスチャーなどを格納します。

プロジェクトの新規作成

  1. [File] メニュー → [New] をクリックします。

  2. [New] ダイアログで、CityEngine フォルダー → [CityEngine project] を選択し、[Next >] をクリックします。

  1. [Project name] に任意のプロジェクト名 (ここでは「MyProject」とします) をつけ、[Finish] をクリックします。

  2. [Navigator] ウィンドウに作成した新規プロジェクトが表示されます。

シーン ファイルの作成

プロジェクトを作成したら、シーン ファイルを作成します。 データを追加した状態でシーンを保存すると、いつでも保存した状態のシーンを開き直すことができます。

  1. [Navigator] ウィンドウにあるプロジェクトから scenes フォルダーを右クリック → [New] → [CityEngine Scene] を選択します。

  1. [CityEngine Scene] ダイアログで、[Project folder:] でシーンを保存するフォルダーを指定します。
    特別な理由がない限りはデフォルトの場所に保存することをお勧めします。 フォルダーを変更する場合は、[Browse] ボタンからシーン ファイルを保存するフォルダーを指定します。

  2. [File name:] で、シーン ファイルに名前をつけます。 ここでは「MyScene1.cej」と名付けます。
    ※シーンファイルの拡張子は「.cej」です。

  1. [Coordinate System:] の [Choose] ボタンから座標系を指定します。 CityEngine で使用できる座標系は投影座標系のみです。 GIS データなどすでに特定の地理的な座標系を持っているデータがある場合は、同じ座標系をシーンに指定します。
    今回は、Projected Coordinate Systems フォルダー → World フォルダー から、一般的な WEB マップで使用されている [WGS 1984 Web Mercator (auxiliary sphere) ] を設定し、[OK] をクリックします。

  2. [Finish] をクリックします。 [‘my_city.cej’ has been modified. Save changes? ('my_city.cej’ が変更されています。保存しますか?) ] というメッセージが表示されたら [Yes] をクリックします。これは前回のプロジェクトのシーンを保存するかどうかを聞いています。

  3. ファイルを作成したら、[Navigator] ウィンドウの scenes フォルダーの下に作成したシーン ファイルがあることを確認します。 また、3D View ウィンドウは空の状態になっているはずです。

マップにグリッドを表示したい場合は、3D View ウィンドウ ツールバーの [View settings] をクリックし、[Grid] にチェックをいれることで有効化します。

データの新規作成

CityEngine では GIS データなどの外部のデータをインポートしてそのまま利用することもできますが、自分でデータを一から作成することも可能です。

  1. ツールバーより [Street creation tools] をクリックし、[Polygonal Street Creation] ウィンドウで [Polygonal street creation] または [Freehand street creation] ツールをクリックします。

  2. 3D View ウィンドウ上で区画ができるようにラインを何本か描画します。

また、[Move]、 [Scale]、 [Rotate] ツールなどを用いて自由に編集しても構いません。 さらに [Edit streets/curves] ツールを用いることで道路幅などを変更して車線を増やしたり、カーブをつけたりすることができます。

道路端部は、[Inspector] ウィンドウで [Nodes] タブの [Type] にて変更可能です。 また、端部の違いによる演習への影響はありません。


今回、区画シェープは使用しないので、[Scene] ウィンドウの Streetnetwork レイヤーを展開し、Blocks レイヤーのチェックをはずして非表示にします。

次に、建物用にポリゴン シェープを新規作成します。

  1. ツールバーより [Shape drawing tools] をクリックし、[Polygonal Shape Creation] タブの[Polygonal Shape Creation] や [Rectangular Shape Creation] ツールを使用して、任意の場所に図形を 3 つ以上作図します。ここでも図形の移動や方向転換に [Move]、[Scale]、[Rotate] ツールなどを用いるといいでしょう。

Street Designer で道路構成を作成・管理

ArcGIS CityEngine 2025.0 より、Street Designer の機能が追加され、道路の車線・歩道・植栽などを組み合わせた道路構成を直感的に作成・管理することが可能になりました。 適宜道路構成を任意に変更していきます。

まずは、現在の道路構成を確認します。

  1. [Scene] ウィンドウの Streetnetwork レイヤーを展開し、Network を選択した状態で、右クリック → [Select Objects] ですべての道路が選択されます。

  1. [Inspector] ウィンドウ → [Segments] タブ → [Street Configuration] で選択されている道路構成が現在適用されているものになります。

  1. [Street Configuration] より任意の道路構成を選択すると、道路構成が変わります。

  1. 適用された道路構成は [Street Designer] ツールを使用すると、レーンの幅を変更したり、追加・削除をしたりすることができます。

  1. 他にも、適用された道路構成を細かく調整するには [Inspector] ウィンドウの各タブの設定を変更します。

例として、下の画像では、[Roadbed Lanes] タブ → [Street Materials] の Surface を「Red Asphalt」にして、自転車レーンの色を変更しています。

変更した道路構成を再利用するために保存することも可能です。

  1. [Inspector] ウィンドウ → [Segments] タブ → [Street Configuration] の「+」をクリックすることで道路構成を保存できます。

ルール ファイルの適用

道路や建物のシェープを作成したら、次はルール ファイルを適用します。 今回は CityEngine にあらかじめ付属されているライブラリ Esri.lib のルール ファイルを使用します。

まずは、Esri.lib のルール ファイルを更新します。

  1. [File] メニュー → [Manage ESRI.lib...] をクリックします。

  1. インストールされていないルール ファイルのチェックボックスが自動的にオンとなっています。 このまま [Update] をクリックします。
以前のバージョンをインストールしていた場合や、以降の手順において、テクスチャーがうまく反映されない場合は、[Esri.lib] チェックボックスもオンにして [Update] を実行してください。

自動的にウィンドウが閉じたら、ルール ファイルの更新は完了です。

ここからは、ルール ファイルを適用していきます。 建物のルール ファイルを適用します。 建物のルール ファイルは 3 つ用意されています。 Building_From_Footprint.cga は主に建物のフットプリントなど、平面シェープがあるときに使用します。 対して、Building_Mass_Texturizer.cga は主に立体シェープがあるときに使用します。 また、Building_From_OpenStreetMap.cga は Get Map Data 機能でダウンロードした OpenStreetMap データに使用します。

  1. [Navigator] ウィンドウ → [ESRI.lib] → rules フォルダー → [Buildings] → [Building_From_Footprint.cga] を建物用シェープの 1 つにドラッグ & ドロップします。

  2. 続いて [Navigator] ウィンドウ → [ESRI.lib] → rules フォルダー → [Buildings] → [Building_Mass_Texturizer.cga] を建物用シェープにドラッグ & ドロップします。 今回は立体シェープがないので、高さがない平面の状態でルールが適用されます。

  3. ツールバーより [Push Pull tool] ツールをクリックし、カーソルを建物用シェープの上に当てます。

  4. シェープの中央にオレンジ色の球体が表示されるので、球体をクリックし、ホールドしたままカーソルを上にドラッグします。

  1. 最後にもうひとつルールを適用してみましょう。 [Navigator] ウィンドウ → [ESRI.lib] → rules フォルダー → [Plants] → [Plant_Distributor.cga] を区画シェープにドラッグ & ドロップします (区画シェープにルールを適用する場合は、[Scene] ウィンドウの Streetnetwork レイヤーを展開し、Blocks レイヤーのチェックボックスをオンにします。)

Esri.lib に格納されているルール ファイルには、あらかじめパラメーターがいくつか設定されています。 [Inspector] ウィンドウを開き、パラメーターを変更してみましょう。

例:樹木のシェープを選択し、[Inspector] ウィンドウの [Plant] → [Representation] パラメーターを [Realistic] から [Schematic] に変更

  1. [File] メニュー → [Save] でシーンを保存します。

本項目では、プロジェクトを新規作成し、道路や建物などのシェープの作成、Street Designer により、道路構成を変更、そして、ルール ファイルを適用するまでの流れを学習しました。 これは CityEngine のメイン ワークフローであり、とても重要です。 CGA の作成では、CGA ルール ファイルの作成方法を学習します。

補足 Get Map Data でデータをダウンロード

Get Map Data 機能は、ArcGIS Online から世界中の街の中から選択した任意の範囲の OpenStreetMap の地図データや衛星画像などを切り出してダウンロードし、プロジェクトで利用できる便利な機能です。

  1. プロジェクトを作成し、シーン ファイルを作成します (シーン ファイルの作成参照)。

  2. [File] メニュー → [Get Map Data] をクリックします。

  1. ArcGIS Online アカウントでサイン インします (アカウントを持っていない場合は、アカウントを作成してサインインします)。

  2. 左上の検索ボックスに、移動したい場所 (住所やランドマーク) を入力します。

  3. [Set Extent] をクリックして範囲選択ボックスを表示し、切り出したい範囲を指定します。

  4. ダウンロードしたいデータを指定し、[OK] をクリックし、ウィザードに従って進みます。

  1. ダウンロードが終わると自動的にシーンに追加されます (このダウンロードには ArcGIS Online のクレジットを消費しません)。

  1. Get Map Data をダウンロードすると Building_From_OpenStreetMap.cga が自動的に適用されており、[Inspector] ウィンドウにおいて、ルールのパラメーター (属性) を変更することができます。

OpenStreetMap は、米国 Esri 社および ESRIジャパンが作成している地図データではなく、OSM コミュニティが作成して、公開しているデータです。 その詳細度やレイヤーの種類、格納されているデータの内容は地域によって異なります。 そのため、ダウンロードした地域によっては、ここで紹介した手順と同じ処理が実行できない可能性があります。