基本操作

概要

ここでは、ArcGIS CityEngine の Welcome Wizard を使って、簡単に街のモデルを作成・操作する方法をご紹介します。

演習
CityEngine の起動
City Wizard の利用
街の操作

CityEngine の起動

  1. [スタート] → [すべてのプログラム] → [ArcGIS] → [CityEngine 2020.x] をクリックします(Windows 10 の場合)。
  2. 自動的に「Welcome to CityEngine2021.x」と表示されたダイアログが表示されます。 このダイアログの、[Create an imaginary city] からは、City Wizard を起動して初心者の方でもウィザード形式で簡単に街を作成することができます。

※ 起動時にこのダイアログが出ない場合は、[File] メニュー → [New] → [CityEngine] フォルダー → [City Wizard] から City Wizard を起動し、ステップ 1.2 の手順 1 から始めてください。

City Wizard の利用

  1. Terrain トピックで、[Scene Name] に任意の名前を付けます。Scene(シーン)とは、地形や図形などのレイヤーや設定をひとまとめにするファイルです。

  2. [Next] をクリックします。

  3. Street Graph トピックで、好きな道路ネットワークの形状を選択し、[Next] をクリックします。

  1. Rules トピックで、International City を選択します。

  2. [Finish] をクリックします。手順 1 で指定した名前のプロジェクトが追加され、都市が生成されます。 CityEngine ではプロジェクトと呼ばれるフォルダーごとにデータを管理します。

街の操作

以下の図は CityEngine のインターフェイスです。CityEngine にはさまざまなウィンドウが用意されており、代表的なウィンドウの例です。ウィンドウは、移動して任意の位置に配置することができます。演習を行う際には、Navigator ウィンドウと Scene Editor ウィンドウを以下のように入れ替えて進めます。

ウィンドウ

Navigator: データを管理するウィンドウです。データの追加、削除を行う際に使用します。

Scene Editor: 表示を管理するウィンドウです。レイヤーの表示/非表示などを操作する際に使用します。

CGA Rule Editor: ルール ファイルを表示するウィンドウです。ルールを作成・編集する際に使用します。

3D View: シーンを表示するウィンドウです。

Inspector: 属性を管理するウィンドウです。ルール ファイルやパラメーターの設定を行う際に使用します。

Log: ログを管理するウィンドウです。

標準ツールバー

マップを操作する際に利用できるツールが用意されています。モデルの選択や、移動、図形の作成などをする際に使用します。実際のツール名は英語ですが、各ツールの意味については以下を参考にしてください。

3D View ウィンドウ ツールバー

3D View の上部には、表示設定のためのツールバーがあります。 ※より詳細な説明は [Help] メニュー → [CityEngine Help] からヘルプをご参照ください。 ツールバーを使用して、まずは作成した街のシーンを操作してみましょう。

操作例1(ナビゲーション):

[Pan/Track](平面移動)、[Tumble/Rotate](回転移動)、または [Dolly/Zoom](ズームイン/アウト)ツールを選択し、クリックしながら画面を操作しましょう。これらはそれぞれ、[Alt] キーを押しながらのマウス中ボタン(ホイール)、左ボタン、右ボタンでのドラッグでも行えます。

操作例2(パラメーターの変更):

[Select](選択)ツールで、建物を 1 つクリックして選択します。ここで [F] キーを押すと、この建物にズームします。 Inspector ウィンドウの [Shape] タブ で [HeightFactor](高度係数)パラメーターに任意の値を入力、または、スライダーをドラッグして建物の高度係数を変更しましょう。また、ツールバー上の [Update Seed](モデルの更新)ツールをクリックして、モデルを更新しましょう。

操作例3(ダイナミック シティ レイアウト):

[Move] (移動) ツールで道路を 1 つ選択し、表示された 3 方向の矢印または黄色い円をドラッグして道路の形状、位置を変更しましょう。

操作例4(ダイナミック シティ レイアウト):

道路を追加します。[Polygonal Street Creation] (道路追加)ツールをクリックし、既存道路の端点にカーソルを合わせます。スナップされ、カーソルがオレンジ色の四角形の表示になったら、クリックします。そのまま何もないスペース上でクリックしていくと、新規に道路を作成できます。最後に再度既存道路の端点にカーソルを合わせ、スナップされたらダブルクリックで道路追加の作業を終了します(道路追加の作業の編集は [Esc] キーを押すことで終了することもできます)。道路を繋いで区画ができると、区画にルールが自動的に適用され、街ができます。

操作例5(効果):

ビューの設定からは、さまざまな効果や表示を行うことができます。[View Settings](ビューの設定) の右の三角 [▼] をクリックして開きます。各機能をオン、オフに切り替えて、効果や表示がどのように変わるのかを試してみましょう。

このように、CityEngine はアルゴリズムで建物や道路の 3D モデルを生成しているため、簡単で対話的な操作性で思い通りの都市を作成・編集することができます。 建物や道路のモデルを選択して、Inspector ウィンドウの “Rule File” で設定したファイルが、そのアルゴリズムを記述したルール ファイルです。もととなる図形からこれに書かれた手順に従って 3D モデルが生成されており、その図形を編集するとすぐにまたルールに従ってモデルが再生成され、このようなレイアウト変更が可能になるのです。

[File] メニュー → [Save] でシーンを保存します。