クラシック レポート テンプレートの作成

本演習にかかる時間はおよそ 30 分です。

このチュートリアルでは、クラシック レポート テンプレートの作成・配置方法、デザインの編集方法について学びます。本演習を通じて、以下のようなレポート テンプレートを作成します。

演習用プロジェクトの起動

BA Pro を起動して、任意の名前でプロジェクトを作成します。既存のプロジェクトを開いて演習を行っていただくことも可能です。

新規プロジェクトの作成方法は、ArcGIS Pro 操作ムービーをご覧ください。

Business Analyst データ ソース が最新のデータセットに設定されていることをご確認ください。

空のテンプレートの作成

[クラシック レポート エディター] を起動して、空のレポートテンプレートを準備します。

  1. [解析] タブ→ [ビジネス解析] → [インフォグラフィックス エディター] をクリックします。
  2. [テンプレートの構築] → [クラシック レポート] をクリックします。

    [クラシック レポート エディター] が表示されます。

コンテンツの追加

クラシック レポート テンプレートにコンテンツを追加するには

  • 既存テンプレートから追加する方法
  • データ ブラウザーから変数を追加する方法

の2つの方法があります。

既存テンプレートから追加する方法

既存のクラシック レポートを利用して、コンテンツを追加することが可能です。

  1. [レポートの選択] タブ → [サマリーレポート] を展開し、 [年齢別人口・経年比較レポート(Classic)] をクリックします。
  2. [人口総数・男女別人口 経年比較(2015年 → 2020年)] セクションを [3. レポート テンプレートを~] にドラッグ & ドロップで追加します。
  3. 同様に [年代別 人口 増減率(2015年 → 2020年)] セクションをドラッグ & ドロップで追加します。

データ ブラウザーからコンテンツを追加する方法

データ ブラウザーから、ドラッグしてコンテンツを追加することが可能です。

  1. [3. レポート テンプレートを~] の [編集] をクリックします。

  2. [アイテムの挿入] → [テーブル] をクリックします。

  3. [テーブル プロパティ] ダイアログで以下のようにプロパティを設定し、[適用]をクリックします。

  4. [変数の選択] タブをクリックします。

  5. [世帯] → [世帯総数] → [2015 世帯総数 (国勢調査)] を展開して、 [2015 世帯数 総数] をテーブルの2 行2 列目にドラッグ & ドロップで追加します。同様に、以下の変数をテーブルに追加します

    • 2 行目 3 列目:[2020世帯総数] -> [2020 世帯数 総数]
    • 2 行目 4 列目:[世帯増減率] -> [2015-2020 世帯数 総数 増減率(%)]
  6. [1.変数を参照~] で [世帯] → [世帯人員] を展開して、以下の変数をテーブルに追加します。

    • 3 行目 2 列目:[2015 平均世帯人員(国勢調査)] -> [2015 一般世帯1世帯当たり人員]
    • 3 行目 3 列目:[2020 平均世帯人員(国勢調査)] -> [2020 一般世帯1世帯当たり人員]
  7. 以下のように列名と項目名を変更します。

  8. 6 列目の1 行目をクリックします。続けてシフト キーを押しながら、6 列目の3 行目をクリックしてセルを選択した後、スパナのアイコンをクリックして、[テーブルの変更] で [セルのマージ] をクリックします。

  9. 2 行目の2 ,3 列目を選択した後、スパナのアイコンをクリックして、[チャートの作成] で [水平バー チャート] をクリックします。

  10. 水平バー チャートをマージしたセルにドラッグ & ドロップで移動させます。チャートのあったセクションは削除します。

  11. [セクション オプション] → [セクション タイトル] に「年代別 世帯数及び 一般世帯1世帯当たり人員 経年比較 (2015年 → 2020年)」と入力します。

  12. 以下のようにレイアウト及びセルの書式を設定します。セルをクリックした後、スパナのアイコンをクリックして、[セルのスタイル] や [テーブルの変更] から変更します。また、チャートの書式を変更するには、チャートにカーソルを合わせ、[チャートの変更] をクリックします。

マップの追加

レポート テンプレート にマップを追加します。

  1. [アイテムの挿入] → [マップ] をクリックします。
  2. [マップの参照と選択] ダイアログから [地形図] を選択します。

レポート テンプレートの保存

作成したレポート テンプレートを繰り返し使えるようにするため、保存を行います。

  1. [クラシック レポート エディター] タブの [保存] をクリックします。
  2. [レポート テンプレートの保存] ダイアログの [タイトル] に「カスタムレポート(Classic)」と入力して [保存] をクリックします。
  3. [マイ レポート] に作成したテンプレートが追加されます。

保存されたテンプレートの場所の設定

デフォルトではプロジェクトファイルがあるフォルダー内の [Business Analyst Templates] フォルダーに保存されます。

作成したテンプレートを保存する場所は以下の手順で設定できます。

  1. [プロジェクト] タブをクリックして、[オプション] をクリックします。
  2. [オプション] ダイアログ ボックスの [アプリケーション] 見出しの下で、[Business Analyst] をクリックします。
  3. [レポート テンプレートのオプションの設定] で、次のいずれかを選択します。
    • [プロジェクトのホーム フォルダーを使用] を選択
    • [この場所を使用] を選択して、任意のフォルダーを参照
  4. [OK] をクリックして、[オプション] ダイアログ ボックスを閉じます。

クラシック レポートの実行

作成したレポート テンプレートを利用して、レポートを作成します。

クイック商圏の作成

分析対象となる商圏を作成します。[クラシック レポート エディター] タブを閉じて、マップを表示させます。

  1. [解析] タブ → [ワークフロー] グループの [ビジネス解析] ボタン → [クイック商圏] をクリックします。

    [クイック商圏] ウィザードの [ステップ 1: 位置] で、解析対象となる位置を指定します。

  2. [場所検索] タブを開き、検索ボックスに「西船橋駅」と入力し、Enter キーを押します。

  3. 検索結果が表示されるので、選択して [次へ] をクリックします。

    [ステップ2: バッファー] で商圏を作成します。

  4. [道路距離/時間商圏] タブを選択し、以下のように設定し、[次へ] をクリックします。

    • 距離タイプ: 運転時間 (平常時)
    • 時間: 「5」と入力します。単位は「分」に設定します。
    • ディゾルブ オプション: ディスク
  5. [ステップ3: 解析] では、何も設定せず [次へ] をクリックします。

  6. [ステップ4: サマリー] で設定内容を確認し、[完了] をクリックします。

ツールが実行され、マップ上に商圏が追加されます。

サマリーレポートの実行

作成した商圏を対象としたレポートを作成します。

  1. [解析] タブ → [ジオプロセシング] グループの [ツール] をクリックします。
  2. [ツールボックス] タブを選択し、[Business Analyst ツール] → [レポート] → [サマリー レポート (Summary Reports)] を開きます。
  3. [入力フィーチャ] のプルダウンから「クイック商圏¥バッファー」レイヤーを選択します。
  4. [レポートの作成] のプルダウンから「マイ レポート」 → [カスタムレポート(Classic)] のチェックボックスをオンにし、[追加] をクリックします。
  5. [実行] をクリックします。
  6. [ジオプロセシング] ウィンドウ の[詳細の表示] をクリックし、[パラメーター] タブの [出力ファイル] をクリックします。 レポートが出力されていることを確認します。

まとめ

このチュートリアルでは、空のテンプレートからクラシック レポート テンプレートを作成する方法を学びました。また、クイック商圏で商圏を作成し、カスタム レポートを出力する方法を学びました。